cant get ls1 programming harness to connect

160 And 8192 Baud Aldl
Posts: 5
Joined: Sun Dec 30, 2012 10:33 am

cant get ls1 programming harness to connect

Postby turbo1600 » Sat Nov 02, 2019 3:31 pm

they seem to vary abit but i`ve built a ls1 `0411 programming harness.

this is what i`ve done :
ob2 pin 2 to blue ecm pin 58
ob2 pins 4 and 5 to power ground
ob2 pin 16 to positive power ( 12vdc)
blue ecu pin 60 to power ground and obd pins 4 and 5
pins 19 and 20 to + 12 vdc

also what is best interface to use with pcm hammer, and OSE enhanced flash tool ?

any one help me out ?

thanks.

Posts: 144
Joined: Sat Dec 15, 2018 7:38 am

Re: cant get ls1 programming harness to connect

Postby Gampy » Sat Nov 02, 2019 7:50 pm

Wiring looks ok, matches what I have ...

Pcm Connector - Blue
Pcm pin 19...-> Switch (ignition) -> +12v
Pcm Pin 20...-> +12v
Pcm Pin 58...-> OBDii Pin 2
Pcm Pin 60...-> Grond (Earth) (-12v)
OBDii Pin 4...-> Grond (Earth) (-12v)
OBDii Pin 5...-> Grond (Earth) (-12v)
OBDii Pin 16.-> +12v

Yes, the switch is important, there are times the Ignition must be switched without powering down the unit.

As for the interface, See here and the following couple of posts.

[edit]
Not pushing this product by any means, however the SparkFun OBD-II UART works great albeit slow! You will need to grab a way to connect it to the PC, something like SparkFun Serial Basic Breakout - CH340G or SparkFun FTDI Basic Breakout - 5V and a 6 pin male header to connect the two together.
I used the FTDI and 6 pin right angle header. (got it as a gift a few years back)

And when I say slow, I mean SLOW ... [12:26:54:212] Elapsed time 02:26:41.0419922 for a full 1m (p59) read.

-Enjoy

Return to ALDL, OBDII Logging and Scanning

Who is online

Users browsing this forum: No registered users and 8 guests