2001 TS Astra going into limp mode

A place For General Chit Chat Etc
Posts: 1
Joined: Tue Dec 01, 2020 4:47 pm

2001 TS Astra going into limp mode

Postby kcwelch » Tue Dec 01, 2020 5:52 pm

Another newbie here
I am having problems with a 2001 holden astra ts ( stop feeling sorry for me ) . It all started after a wheel alignment . My wife picked up the car and was going through town when the traction light came on and the car went into limp mode. The RACT was called and because they couldn't find the fault it was picked up taken to our service mechanic. I contacted people who did alignment and they said fault had no bearing. The mechanic rang and said the automatic transmission control ECU was at fault. I purchased 2nd hand one and was fitted but after a short run fault back again. Back to mechanic and after further testing advised engine ECU required. After the car has been left for a while the dash light goes out and I can drive again but it appears as soon as the car warms up it comes on again. Up to now it has been a good car but the dollars are starting to mount up. Any advise would be appreciated

Posts: 1349
Joined: Sat Aug 06, 2011 7:58 am
Location: Padstow NSW

Re: 2001 TS Astra going into limp mode

Postby Charlescrown » Wed Dec 02, 2020 1:00 pm

After a wheel alignment? I wonder if they have damaged an ABS sensor cable in the process. Traction control is linked with the ABS. A good scan tool should be able to monitor the sensors as you drive and see if one drops out when the light comes on.

Return to Off Topic

Who is online

Users browsing this forum: No registered users and 11 guests