converting harnes to vs 304 engine

Converting To Delco ECU From Carby Or Other Injection Systems
Posts: 50
Joined: Fri May 10, 2019 12:11 pm
Location: Sydney

converting harnes to vs 304 engine

Postby Humptydumpty » Fri May 10, 2019 12:35 pm

Hi guys and gals,

First time on this forum thanks for having me.......

So in a nut shell - im fitting a 1999 304 v8 in a Toyota Bundera (using the Toyota manual gearbox) :punk:

I have purchased a engine wiring loom and ecu out of a VP 304 commodore (it already has the relays for fuel pump and power supply to loom etc... just a very simple n cheep way to set it up)

The issues I need help with are the following:

- The vs dizzy has a 4 pin plug - the vp only has 3 (can anyone help me wire up the 3 to the vs dizzy please)

- The vs has a o2 sensor - im told the vp loom has a input for the o2 but im not sure where it is and also was told its a single wire where the vs has 4 pin again)

- also ive been told I will have problems with the speed control sensor/signal setup?


- Basically everything else plugs straight into the engine (accept the vp loom doesn't have a knock sensor)

I have the original loom but its been cut in half and was beyond my abilty to re connect it all back :|


Thanks heeps :thumbup:

User avatar
Posts: 9788
Joined: Sat Feb 28, 2009 9:05 pm
Location: Tenambit, NSW

Re: converting harnes to vs 304 engine

Postby Holden202T » Fri May 10, 2019 12:59 pm

ok firstly i have moved this out of the LS1 pcm area to here.

with the 4 wire plug, i believe that is the series 3 VS which is the same as the VT series 1 motor.

If that is in fact correct, in the below picture, the three wires going from the crank sensor to the ignition module should be the ones you need - someone else please correct me if im wrong.

dizzy1.jpg
dizzy1.jpg (60.23 KiB) Viewed 722 times

my diagrams show the colours should match, its just the 4 pin plug has the extra black wire in it for the cam sensor.

id probably recommend getting the right o2 sensor to match the model of computer your using, but you can also use the 4 wire sensor but you'd need to add the extra wires it needs - 2 x for the heater circuit and 1 for the sensor ground. the earlier model doesnt have these, and its one wire should be purple with a round pin plug on it i believe. (pin D7 in the ECU)

i have no idea what the toyota gearbox has as far as a speed sensor so cannot comment on that.

Posts: 525
Joined: Sun Jun 06, 2010 9:59 am
Location: Perth

Re: converting harnes to vs 304 engine

Postby Dazza92VP » Fri May 10, 2019 1:22 pm

The 4runners and hiluxs use a Hall effect sensor the last one I did I used the old signal wire to the factory ecu and it worked fine just changed the pulses to suit. If it’s the same box as them should be the same sensor only way is to try it see if the ecu reads a speed. Only other problem you will have if it is a s3 vs motor the intake temp sensor is in the box on the vs and it’s in the manifold on the vp I would recommend changing the location to the manifold if it is so it reads charge temp correctly

Posts: 50
Joined: Fri May 10, 2019 12:11 pm
Location: Sydney

Re: converting harnes to vs 304 engine

Postby Humptydumpty » Fri May 10, 2019 2:27 pm

Thanks heeps!!! This is very helpful information. Sorry don’t know how I managed to put it in the ls1 page.
I think just ussing the earlier o2 sensor makes sense.

Cheeers ledgends

Tim

Posts: 50
Joined: Fri May 10, 2019 12:11 pm
Location: Sydney

Re: converting harnes to vs 304 engine

Postby Humptydumpty » Fri May 10, 2019 2:29 pm

Thanks guys this is great!

Posts: 50
Joined: Fri May 10, 2019 12:11 pm
Location: Sydney

Re: converting harnes to vs 304 engine

Postby Humptydumpty » Fri May 10, 2019 2:49 pm

Hey guys,
Had a quick look and the vp wire and the vs dizzy wires and they are different colours (the blacks there and I understand I do t need that one) go looms spears to be a light green, red n black or grey, and white the vs has Black, green, red, blue...


IMG_2913.HEIC

IMG_2912.HEIC

Trying to figure out which wire would go to what?
Sorry I’m not very tech with this stuff...

Thanks

Private message if it’s easier n I’ll txt u through everything - also how do I ad pics? Dont think mine worked

Posts: 525
Joined: Sun Jun 06, 2010 9:59 am
Location: Perth

Re: converting harnes to vs 304 engine

Postby Dazza92VP » Fri May 10, 2019 4:02 pm

Sure it’s the right connector as they all have the same coloured wires light blue with white trace, grey with red trace and white with black trace and the vs/vt one has the added black for cam

Posts: 50
Joined: Fri May 10, 2019 12:11 pm
Location: Sydney

Re: converting harnes to vs 304 engine

Postby Humptydumpty » Fri May 10, 2019 5:29 pm

Yeah 100% the the 4 wires coming out of the dizzy army the same colour as the plug.

It’s a gm original dizzy to... mmmmm confusing...

I can txt or email through the pics if that helps?

Posts: 525
Joined: Sun Jun 06, 2010 9:59 am
Location: Perth

Re: converting harnes to vs 304 engine

Postby Dazza92VP » Fri May 10, 2019 6:21 pm

Yea mate I sent you a message if you send those pics though I’ll fix your post as well

Posts: 386
Joined: Thu Nov 03, 2011 7:57 pm
Location: perth wa

Re: converting harnes to vs 304 engine

Postby vs ss » Fri May 10, 2019 6:27 pm

Going by what I can work out here your looking at the colors on the pigtail sticking out of the vs/vt dizzy and the color on the vp car harness?

Next

Return to Delco ECU Conversions

Who is online

Users browsing this forum: No registered users and 5 guests