5l knock sensor

General Tuning Questions And Discussions
Posts: 43
Joined: Sun Jul 14, 2013 7:05 am
Location: PERTH

5l knock sensor

Postby vn_ss_cm » Tue Oct 01, 2019 8:36 pm

Hello guys,

I have a wierd issue my memcal does not have a knock filter board connected and the knock sensor settings disabled in the tune. Since it's disabled I decided to remove the knock sensor and plug but I get code 42, and the tacho bounces all over the place..when I plug it in car runs perfect so confused

Site Admin
User avatar
Posts: 6036
Joined: Sat Feb 28, 2009 8:34 pm

Re: 5l knock sensor

Postby antus » Tue Oct 01, 2019 10:30 pm

Sounds like a wiring issue. 42 is a problem on the EST circuit to the ignition module. I'd be checking the wires go where you think they go, between the ignition module and the pcm, and the knock sensor and the pcm. Maybe someone has wired a power connection through the sensor in error and gotten away with it until now, or similar.
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

Posts: 43
Joined: Sun Jul 14, 2013 7:05 am
Location: PERTH

Re: 5l knock sensor

Postby vn_ss_cm » Wed Oct 02, 2019 7:23 pm

Thanks Antus.

I have check the wiring against my diagrams and everything is correct the knock sensor wire was connected to B11. With it unplugged the car get the engine light even though in the mental it was set to never work lol
Last edited by vn_ss_cm on Wed Oct 02, 2019 8:08 pm, edited 1 time in total.

Posts: 1160
Joined: Sun Mar 15, 2009 10:20 am
Location: Geelong, VIC

Re: 5l knock sensor

Postby yoda69 » Wed Oct 02, 2019 7:31 pm

Seems a little strange, wondering if it maybe an error in the xdf?
What bin and xdf are you using?

Posts: 43
Joined: Sun Jul 14, 2013 7:05 am
Location: PERTH

Re: 5l knock sensor

Postby vn_ss_cm » Wed Oct 02, 2019 8:10 pm

It's a VP clubsport bin and $DB

Posts: 43
Joined: Sun Jul 14, 2013 7:05 am
Location: PERTH

Re: 5l knock sensor

Postby vn_ss_cm » Thu Jan 16, 2020 7:56 pm

Hello Guys

Sorted out the issue the tune had knock enabled....question is it possible to hook up a resistor to trick the ecu into thinking a knock sensor is connected?

Site Admin
User avatar
Posts: 6036
Joined: Sat Feb 28, 2009 8:34 pm

Re: 5l knock sensor

Postby antus » Thu Jan 16, 2020 8:37 pm

I assume that would be possible, but the harder part is the knock filter. if you get that wrong you get false knock, and if you have the v8 filter, you might as well put a sensor on it, or sell it and disable the sensor in the tune.
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

Posts: 43
Joined: Sun Jul 14, 2013 7:05 am
Location: PERTH

Re: 5l knock sensor

Postby vn_ss_cm » Thu Jan 16, 2020 9:49 pm

ah I see the thing is it has no knock filter board.....the tune has the knock sensor disabled by adjusting the ESC parameter but the code 43 is still active so when the car starts it goes into limp mode and comes up with - knock sensor code (43
would a resistor in its place trick the memcal? if so what resistance?

Posts: 1257
Joined: Sat Aug 06, 2011 7:58 am
Location: Padstow NSW

Re: 5l knock sensor

Postby Charlescrown » Fri Jan 17, 2020 6:45 am

3300 to 4500 ohms.

Site Admin
User avatar
Posts: 6036
Joined: Sat Feb 28, 2009 8:34 pm

Re: 5l knock sensor

Postby antus » Fri Jan 17, 2020 8:16 am

I'll be interesting to see if that works. without the knock board I suspect it work. I think you also need to toggle the CEL flag for code 43 in the tune to stop it lighting the CEL rather than a hardware mod. Perhaps that flag isnt defined for DB and thats your problem.
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

Return to General Tuning Discussion

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests