Cold start car stalls when taking off help needed

General Tuning Questions And Discussions
Posts: 272
Joined: Wed May 19, 2010 2:21 pm

Cold start car stalls when taking off help needed

Postby vp304 » Wed Mar 24, 2021 12:52 pm

So my l67 swap in my vr on 11p 2 bar has been running great now for 2 plus months as my daily driver.
The last 2 weeks tho has come up with this weird problem.
Which i thought i fixed when doing the cold starts 2 plus months ago when tuning it.

From stone cold in the morning or after work etc.
Jump in turn key starts and after say 5 sec or so idle comes down to around 1000rpm or so put car in drive turn steering wheel like loading up the engine go to take off outa parking spot and car stalls.

Fire it back up put straight into drive and it takes off like nothing happened

I have noticed
The more throttle you give it the more it splutters to stall.
If i am very very light like maybe 5% throttle it will stutter but usually not stall.

Once u restart the car it runs starts smooth no hesitation of idle at all even when warm etc.

When l67 was fitted 3000km ago
Had new walbro genuine fuel pump
New fuel filter fitted
Ultrasonic cleaned injectors.
Have wideband street and dyno tuned car and runs good all round besides this weird problem that has come outa no were.

I notice in the log also the MS for fuel shoots up a fair bit at that stall point. When i restart the car 2nd time after stall and take off again it does not shoot up no were near as badly ?
Im guessing the ms value is how much fuel its injecting the higher the MS the more fuel ? Correct me if im wrong i only know the basics.

Any help will be appreciated thanks

Here is a log below, and screen shot
Start car from stone cold and around 10sec in i go to take of with around 25% tps and it stalls and i just restart and take off again driving slow like nothing happened.
Attachments
cold start stall marc 2021.xdl
(60.36 KiB) Downloaded 7 times
Start and stall at 10sec in .jpg

Posts: 1363
Joined: Sat Aug 06, 2011 7:58 am
Location: Padstow NSW

Re: Cold start car stalls when taking off help needed

Postby Charlescrown » Wed Mar 24, 2021 4:53 pm

Can you please post the ADX your using to view your log. Mine shows a blank so I must be using the wrong one.

Posts: 272
Joined: Wed May 19, 2010 2:21 pm

Re: Cold start car stalls when taking off help needed

Postby vp304 » Wed Mar 24, 2021 5:30 pm

Not in front of pc at moment but it's the 11p adx of here
2 bar. I can get it later when home and on my pc

User avatar
Posts: 6865
Joined: Mon Oct 08, 2012 6:41 pm
Location: Kyneton, Vic

Re: Cold start car stalls when taking off help needed

Postby vlad01 » Wed Mar 24, 2021 5:35 pm

Where's the WB trace on the graph?
I'm the director of VSH (Vlad's Spec Holden), because HSV were doing it ass about.

Posts: 272
Joined: Wed May 19, 2010 2:21 pm

Re: Cold start car stalls when taking off help needed

Postby vp304 » Wed Mar 24, 2021 6:56 pm

Is no wideband hooked up to the car

User avatar
Posts: 6865
Joined: Mon Oct 08, 2012 6:41 pm
Location: Kyneton, Vic

Re: Cold start car stalls when taking off help needed

Postby vlad01 » Wed Mar 24, 2021 7:08 pm

How do you tune it?
I'm the director of VSH (Vlad's Spec Holden), because HSV were doing it ass about.

Posts: 272
Joined: Wed May 19, 2010 2:21 pm

Re: Cold start car stalls when taking off help needed

Postby vp304 » Wed Mar 24, 2021 8:04 pm

Wideband sniffing of the rear using a innovate mtx with its own display. I known not the best for. Cold starts but what I do for that is power it straight of a separate battery so it's ready to go as soon as I start the car

User avatar
Posts: 280
Joined: Sun Oct 28, 2012 12:57 pm

Re: Cold start car stalls when taking off help needed

Postby 'quipt4it » Thu Mar 25, 2021 7:54 am

Looks like a cold start issue.
Cooler temps lately where you live? Look at the table breakpoints : A/F Ratio - Cold Engine A/F Ratio vs Coolant Temp and MAP.
On it's own it may not be an issue, however if you combine it with maybe too high cranking pulsewidth it can be.
Look at : Crank - First Stage Crank Base Pulse Width vs Coolant Temp compared to Second Stage.
Is it hunting? Looks like it would be.
See if it's setting any codes.

Posts: 272
Joined: Wed May 19, 2010 2:21 pm

Re: Cold start car stalls when taking off help needed

Postby vp304 » Thu Mar 25, 2021 8:21 am

quip4it thanks for the help again.
here is a screenshot of those maps around 6 sec into that log with data tracing on showing were its at.

The car starts no worries like a standard car warm or cold no worries.

I am in melbourne slightly colder nothing major tho.

I got a basic idea of how the 1st and 2nd stage work as the car needs a lot more fuel to start up and that initial start etc.

Any idea on how long that 2nd stage runs for once the car starts and is running? Maybe its pumping in 2 much fuel when cold and spluttering to a stall.

How do the Cold engine Air fuel ratio tables work? Ie factory narrowband only goes down to 14.0 afr if im correct how does it do the fueling for numbers below that if narowband sensor cant pickup adjust to suit ?
Attachments
1st stage 2nd stage fuel.jpg

User avatar
Posts: 280
Joined: Sun Oct 28, 2012 12:57 pm

Re: Cold start car stalls when taking off help needed

Postby 'quipt4it » Thu Mar 25, 2021 9:25 am

The cranking fuel is only momentary. There is a decay period vs cranking time, and when the RPM is met (400 RPM) it ceases.
If no start, it moves to the secondary stage after a number of reference pulses.
It is also relative to your injector size, bias add on etc. as to how much you need.
By 6 seconds it's all over (the screenshot).
See the 8 degree vs 20 degree breakpoints at 30 KPA in your Cold AF/R vs Coolant Temp. table, there is quite a difference in AF/R.
You have to judge what the temps are and maybe work between those 2 areas, either adding, subtracting or blending.
I would think it needs less.

Next

Return to General Tuning Discussion

Who is online

Users browsing this forum: No registered users and 3 guests