J2534 tool ? Nano ? MDI2 ?

Programs / Tools / Scripts
Posts: 18
Joined: Sun Jul 05, 2020 10:18 am

Re: J2534 tool ? Nano ? MDI2 ?

Postby gjestico » Sun Apr 11, 2021 1:18 am

This is usb wired. I got a dedicated laptop just for this purpose, Installed the supplied hard drive, Looks like its windows 7 . I have not installed any other programs on it, Dont even know if there is anti virus.
In that 'Device manager' popup that I dont seem to be getting, What version shows on yours ?. Checking that reset tool box does nothing.

One thing I note is that in all the videos I have seen on these clones, They all have the identical serial number as mine, ending in 9579

Posts: 251
Joined: Thu Feb 13, 2020 11:32 pm

Re: J2534 tool ? Nano ? MDI2 ?

Postby ironduke » Sun Apr 11, 2021 1:38 am

Yeah, the clones all have the same serial number.. I can change them on the MDI 1's, I don't have a mdi2 clone so I don't have any ideas on that.. I still have 1 clone with that serial number I think, I'll check and try using sps with it but it has always been working without an issue so I doubt gm blacklisted the serial #..

I'm running mdi version 8.5.33.53, yours should be the same since you downloaded it from bosch.. It says device explorer (v1.5.1.0) on the top of the connection popup where the MDI shows up.. Just to make sure, you are selecting MDI and not mdi2 to try and connect? Should show up a popup even if you chose the wrong one, but want to double check..

if you go to add remove programs are you showing J2534 wrapper as installed? tis2web proxy? honestly don't remember what else is needed, there's a bunch of others but I have techline connect installed and now there's a lot of doubles and extras you probably don't have..

Not sure if windows 7 works anymore? hopefully someone else can chime in with windows 7 still running on something as I have windows 10 on everything now, might have a vm somewhere, I'll try and check..

Posts: 18
Joined: Sun Jul 05, 2020 10:18 am

Re: J2534 tool ? Nano ? MDI2 ?

Postby gjestico » Sun Apr 11, 2021 2:05 am

Thats the thing....I never get that device explorer popup so cant choose device...

Ya I show the wrapper installed...version 1.05.1

I see in the online vids that that device explorer version looks like 1.4.8.0 ......hmmmm

Posts: 251
Joined: Thu Feb 13, 2020 11:32 pm

Re: J2534 tool ? Nano ? MDI2 ?

Postby ironduke » Sun Apr 11, 2021 2:16 am

When the sps page opens there is a settings box on the lower left, click that, then diagnostic, then checkmark the allow old j2534 driver installation and then click ok.. might have to close that sps page and open an new one, see what happens??

I'm about out of ideas, it should work..

viewtopic.php?f=3&t=6666 This tool I believe will work with your clone, see if this can connect and read your E38 ecu..

Posts: 18
Joined: Sun Jul 05, 2020 10:18 am

Re: J2534 tool ? Nano ? MDI2 ?

Postby gjestico » Sun Apr 11, 2021 2:39 am

Still not working. Heres my installed programs
Attachments
sps3.png

Posts: 33
Joined: Mon Oct 21, 2019 4:58 am

Re: J2534 tool ? Nano ? MDI2 ?

Postby kostia111 » Sun Apr 11, 2021 9:36 am

what is your system 32 64
Java should be 32
I have a system 64 Java 32 (7 update 21)
and everything works

read somewhere what else is needed
NET Framework


do not wait for a window with the choice of adapter
click next
it will appear

User avatar
Posts: 2424
Joined: Thu May 17, 2012 8:53 pm
Location: WA

Re: J2534 tool ? Nano ? MDI2 ?

Postby Tazzi » Sun Apr 11, 2021 12:14 pm

Few things:
1) Ensure you are running compatible Java
2) Disable any antivirus which could be blocking applications or popups from occurring.
3) Install older version of J2534 wrapper. I am still using very old version since they keep making new mistakes and problems in newer releases
Your Local Aussie Reverse Engineer
Site:www.envyouscustoms.com
Mob:+61406 140 726
Image

Posts: 18
Joined: Sun Jul 05, 2020 10:18 am

Re: J2534 tool ? Nano ? MDI2 ?

Postby gjestico » Sun Apr 11, 2021 1:05 pm

Thanks Tazzi. I have latest Java download, Is that compatible ? I had a feeling the wrapper might be an issue. No antiviurs (that i see) on the provided disk. But where do I find an older version ? Can you help ?

User avatar
Posts: 2424
Joined: Thu May 17, 2012 8:53 pm
Location: WA

Re: J2534 tool ? Nano ? MDI2 ?

Postby Tazzi » Mon Apr 12, 2021 9:52 am

gjestico wrote:Thanks Tazzi. I have latest Java download, Is that compatible ? I had a feeling the wrapper might be an issue. No antiviurs (that i see) on the provided disk. But where do I find an older version ? Can you help ?

Might be the wrapper??
I will see if I cant find the one thats installed on my computer.

I have installed 1.04.5.0

I havent updated in a long time for this reason, since if its all working, why update.

Ok so, I cannot find the original installer (j2534installer.msi), but zipped up and attached is my J2534 wrapper which on a 64bit computer needs to be placed at: C:\Program Files (x86)\GM\
Attachments
J2534Wrapper.zip
(4.58 MiB) Downloaded 21 times
Your Local Aussie Reverse Engineer
Site:www.envyouscustoms.com
Mob:+61406 140 726
Image

Posts: 18
Joined: Sun Jul 05, 2020 10:18 am

Re: J2534 tool ? Nano ? MDI2 ?

Postby gjestico » Mon Apr 12, 2021 11:23 am

Thanks Tazzi, I very much appreciate that. I deleted the old wrapper in that location and substituted yours, And I was able to get farther than i have before, All the way to this :
Yes I am using a bench harness. Hitting ok on that window sends everything back to square Zero.
Attachments
sps6.png

PreviousNext

Return to Tools

Who is online

Users browsing this forum: No registered users and 9 guests