Delco OSE FlashTool V1.51

Programs / Tools / Scripts
User avatar
Posts: 569
Joined: Wed Jan 27, 2010 9:45 pm
Location: Melbourne, VIC

Re: Delco FlashTool V1.51

Postby krusty » Fri Jun 26, 2015 7:57 am

Thanks for the help yesterday all. Much appreciated. Happy customer :thumbup:

User avatar
Posts: 2
Joined: Sun Jun 28, 2015 10:23 am
Location: Melbourne, Australia

Re: Delco FlashTool V1.51

Postby III ROMEO III » Thu Jul 02, 2015 3:16 am

nice work thank you

Posts: 210
Joined: Thu Dec 20, 2012 5:28 pm
Location: Melbourne

Re: Delco FlashTool V1.51

Postby Chuff » Tue Aug 04, 2015 11:59 am

Hey all,

Having a bit of a problem here.

I've played with 808 ECUs in the past, but this is the first time on a 16233396 PCM out of a VT V6.

I've got a spare 16233396 and I've followed the "Clone PCM" instructions as found here: http://pcmhacking.net/forums/viewtopic.php?f=3&t=82&start=40#p6472. I'm not sure if the instructions are specific to VX & VY PCMs, but as the PCMs are the same 16233396, I figured that the instructions would apply to a VT as well.

I set my preferences as follows. The only deviation from the instructions is I select "Flash PCM Auto Fix Checksum", but I have tried both TRUE & FALSE Values and got the same outcome regardless:

Preferences.png
Preferences.png (20.55 KiB) Viewed 2895 times


And this is what I keep getting.

10:58:34 AM FlashTool Version 0.1.5.1 Program Loading...
10:58:34 AM Program Ready
10:58:37 AM User Options Loaded From System
10:58:41 AM Prest Options Loaded: Flash PCM in Vehicle
10:59:56 AM User Options Saved To System
11:00:00 AM Starting Connect To Device...
11:00:00 AM COM5 Open
11:00:00 AM Check if Logger V2 in partial passthrough mode
11:00:00 AM Not a logger V2
11:00:00 AM COM5 Port open already
11:00:00 AM Waiting For HeartBeat...
11:00:00 AM Found A HeartBeat Frame, Timer Started
11:00:01 AM Found Another HeartBeat Frame After 302mS
11:00:01 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:01 AM Silence Detected
11:00:01 AM Requesting Chatter To Be Disabled For Device F1
11:00:01 AM Chatter Disabled
11:00:01 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:01 AM Silence Detected
11:00:01 AM Requesting Chatter To Be Disabled For Device F7
11:00:01 AM No Response
11:00:01 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:01 AM Silence Detected
11:00:01 AM Requesting Chatter To Be Disabled For Device F7
11:00:02 AM No Response
11:00:02 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:02 AM Silence Detected
11:00:02 AM Requesting Chatter To Be Disabled For Device F7
11:00:02 AM No Response
11:00:02 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:02 AM Silence Detected
11:00:02 AM Requesting Chatter To Be Disabled For Device F7
11:00:02 AM No Response
11:00:02 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:02 AM Silence Detected
11:00:02 AM Requesting Chatter To Be Disabled For Device F7
11:00:02 AM No Response
11:00:02 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:03 AM Silence Detected
11:00:03 AM Requesting Chatter To Be Disabled For Device F7
11:00:03 AM No Response
11:00:03 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:03 AM Silence Detected
11:00:03 AM Requesting Chatter To Be Disabled For Device F7
11:00:03 AM No Response
11:00:03 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:03 AM Silence Detected
11:00:03 AM Requesting Chatter To Be Disabled For Device F7
11:00:03 AM No Response
11:00:03 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:04 AM Silence Detected
11:00:04 AM Requesting Chatter To Be Disabled For Device F7
11:00:04 AM No Response
11:00:04 AM Waiting For 15ms Of Silence With 300ms Timeout
11:00:04 AM Silence Detected
11:00:04 AM Requesting Chatter To Be Disabled For Device F7
11:00:04 AM No Response
11:00:04 AM No Devices Found
11:00:04 AM COM5 closed
11:00:04 AM COM5 already closed



Selecting the following preferences:

Preferences2.png
Preferences2.png (12.91 KiB) Viewed 2895 times


And I connect fine:

11:10:02 AM FlashTool Version 0.1.5.1 Program Loading...
11:10:02 AM Program Ready
11:10:04 AM User Options Loaded From System
11:10:09 AM Prest Options Loaded: VT Eco or S/C in Vehicle
11:12:16 AM User Options Saved To System
11:12:18 AM Starting Connect To Device...
11:12:18 AM COM5 Open
11:12:18 AM Check if Logger V2 in partial passthrough mode
11:12:18 AM Not a logger V2
11:12:18 AM COM5 Port open already
11:12:18 AM Waiting For HeartBeat...
11:12:18 AM Found A HeartBeat Frame, Timer Started
11:12:18 AM Found Another HeartBeat Frame After 305mS
11:12:18 AM Waiting For 25ms Of Silence With 300ms Timeout
11:12:18 AM Silence Detected
11:12:18 AM Requesting Chatter To Be Disabled For Device F1
11:12:18 AM Chatter Disabled
11:12:18 AM Waiting For 25ms Of Silence With 300ms Timeout
11:12:19 AM Silence Detected
11:12:19 AM Requesting Chatter To Be Disabled For Device F5
11:12:19 AM Chatter Disabled
11:12:19 AM Searching For OSE Device...
11:12:19 AM Searching For ECM...Attempt 1...
11:12:19 AM Request Sent
11:12:19 AM Device Found, Identifying...
11:12:19 AM Found Something, But Not OSE Device...
11:12:19 AM Searching For RT Modified Factory Device...
11:12:19 AM Searching For ECM...Attempt 1...
11:12:19 AM Request Sent
11:12:19 AM Device Found, Identifying...
11:12:19 AM Searching For RT Modified Factory Device...
11:12:19 AM Searching For ECM...Attempt 1...
11:12:19 AM Request Sent
11:12:19 AM Device Found, Identifying...
11:12:19 AM Searching For RT Modified Factory Device...
11:12:19 AM Searching For ECM...Attempt 1...
11:12:19 AM Request Sent
11:12:19 AM Device Found, Identifying...
11:12:19 AM Searching For Kalmaker Devices...
11:12:19 AM Searching For Kalmaker SP3
11:12:19 AM Searching For ECM...Attempt 1...
11:12:19 AM Request Sent
11:12:19 AM Device Found, Identifying...
11:12:19 AM Searching For Kalmaker WDS00
11:12:19 AM Searching For ECM...Attempt 1...
11:12:19 AM Request Sent
11:12:19 AM Device Found, Identifying...
11:12:19 AM Searching For Kalmaker WDS20/WDS21/WDS30
11:12:19 AM Searching For ECM...Attempt 1...
11:12:19 AM Request Sent
11:12:19 AM Device Found, Identifying...
11:12:19 AM Searching For Kalmaker WDS40/WDS41/WDS60/WDS61/WDS70
11:12:19 AM Searching For ECM...Attempt 1...
11:12:19 AM Request Sent
11:12:19 AM Device Found, Identifying...
11:12:19 AM Searching For Kalmaker WDS65
11:12:19 AM Searching For ECM...Attempt 1...
11:12:19 AM Request Sent
11:12:20 AM Device Found, Identifying...
11:12:20 AM Searching For Kalmaker WDS50/WDS51
11:12:20 AM Searching For ECM...Attempt 1...
11:12:20 AM Request Sent
11:12:20 AM Device Found, Identifying...
11:12:20 AM Searching For Kalmaker WDSB3/WDSB4/WDSB5
11:12:20 AM Searching For ECM...Attempt 1...
11:12:20 AM Request Sent
11:12:20 AM Device Found, Identifying...
11:12:20 AM Searching For Kalmaker BDS60
11:12:20 AM Searching For ECM...Attempt 1...
11:12:20 AM Request Sent
11:12:20 AM Device Found, Identifying...
11:12:20 AM Searching For Factory Devices...
11:12:20 AM Searching For ECM...Attempt 1...
11:12:20 AM Request Sent
11:12:20 AM Device Found, Identifying...
11:12:20 AM Unknown ECM/PCM Found, Trying A Different Mode
11:12:20 AM Searching For ECM...Attempt 1...
11:12:20 AM Request Sent
11:12:20 AM Device Found, Identifying...
11:12:20 AM Waiting For 25ms Of Silence With 300ms Timeout
11:12:20 AM Silence Detected
11:12:20 AM Requesting Chatter To Be Enabled For Device F5
11:12:20 AM Chatter Enabled
11:12:20 AM Waiting For 25ms Of Silence With 300ms Timeout
11:12:20 AM Silence Detected
11:12:20 AM Requesting Chatter To Be Enabled For Device F1
11:12:20 AM Chatter Enabled
11:12:20 AM Found Factory VT PCM, Version: Factory
11:12:20 AM COM5 closed



Using these 2nd settings, which enabled me to connect, I was able to GET and save CAL, BIN, RAM & EEPROM, but never was the option to Write the BIN file available.

All this was done using the original PCM installed in the car.

I have also installed & connected to the replacement PCM which I'm wanting to use to clone a copy of the original, but I'm getting the same results as above, only being able to get the BIN, CAL etc... by connecting using the 2nd settings.

So now I have extracted and saved from each PCM the BIN, CAL, RAM & EEPROM using the 2nd connection method, but I have yet to figure out how to connect and write the original BIN to the spare PCM.

I also noticed that the "Device ID" in Preferences changed from F7 during the failed "Flash PCM in Vehicle" attempts, to F5 during the "VT Eco or S/C in Vehicle" successful connections, so I tried setting Vehicle to "Flash PCM in Vehicle" and changed "Device ID" to F5 and I was able to connect but I had no additional functionality compared to connecting with Vehicle set to "VT Eco or S/C in Vehicle".

What am I doing wrong?

Thanks
˙ʎɐqǝ ɟɟo pɹɐoqʎǝʞ ǝsǝuıɥɔ ɐ ƃuıʎnq ɹoɟ ʇɥƃıɹ ǝɯ sǝʌɹǝs

User avatar
Posts: 9844
Joined: Sat Feb 28, 2009 9:05 pm
Location: Tenambit, NSW

Re: Delco FlashTool V1.51

Postby Holden202T » Tue Aug 04, 2015 12:17 pm

its not a flash PCM it has an eeprom in it, you'd need an NVRAM in it to be able to write to it, of if not you can use an eeprom eraser/programmer to change whats on it.

Posts: 210
Joined: Thu Dec 20, 2012 5:28 pm
Location: Melbourne

Re: Delco FlashTool V1.51

Postby Chuff » Tue Aug 04, 2015 12:49 pm

Holden202T wrote:its not a flash PCM it has an eprom in it, you'd need an NVRAM in it to be able to write to it, of if not you can use an eprom eraser/programmer to change whats on it.



Well that just spoilt the fun. :sad2:
˙ʎɐqǝ ɟɟo pɹɐoqʎǝʞ ǝsǝuıɥɔ ɐ ƃuıʎnq ɹoɟ ʇɥƃıɹ ǝɯ sǝʌɹǝs

Posts: 226
Joined: Tue May 19, 2009 7:51 pm
Location: Coffs Harbour, Australia

Re: Delco FlashTool V1.51

Postby ToyHicko » Tue Nov 17, 2015 8:35 pm

Hi guy been a while but just tried to download the current version v1.51 and Norton is flagging a WS.Reputation.1. Is anyone else have this issue?

User avatar
Posts: 6428
Joined: Mon Oct 08, 2012 6:41 pm
Location: Kyneton, Vic

Re: Delco FlashTool V1.51

Postby vlad01 » Tue Nov 17, 2015 10:22 pm

ToyHicko wrote:Hi guy been a while but just tried to download the current version v1.51 and Norton is flagging a WS.Reputation.1. Is anyone else have this issue?

Yes! Norton is a POS. Burn it with fire is my suggestion.

But you can tell norton to allow the file.
I'm the director of VSH (Vlad's Spec Holden), because HSV were doing it ass about.

User avatar
Posts: 266
Joined: Sun Jan 25, 2015 4:21 pm
Location: Sydney

Re: Delco FlashTool V1.51

Postby j_ds_au » Fri Jan 22, 2016 10:18 pm

Vl400, Just wondering ... some time ago (25/02/15) you made a version 1.52, which fixed display issues at non-default display resolutions (DPI), yet the version here is still 1.51. Oversight?

Joe.

Hmmm ... just noticed : Last visited:Sun Oct 04, 2015 12:31 pm

Site Admin
User avatar
Posts: 5830
Joined: Sat Feb 28, 2009 8:34 pm

Re: Delco FlashTool V1.51

Postby antus » Sat Jan 23, 2016 10:09 am

Yes, he is on a bit of a hiatis due to life circumstances. I have been in contact with him recently, he is ok but not sure when he will come back. For now do not expect a reply from him.
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

User avatar
Posts: 266
Joined: Sun Jan 25, 2015 4:21 pm
Location: Sydney

Re: Delco FlashTool V1.51

Postby j_ds_au » Sat Jan 23, 2016 9:39 pm

Thanks, Antus.

I understand. He can take whatever time he needs, just glad to hear he's okay.

Joe.

PreviousNext

Return to Tools

Who is online

Users browsing this forum: No registered users and 3 guests