VS V6 Series 1 O2 4-wire earth issues ?

Wiring diagrams and questions
Posts: 147
Joined: Wed Jul 01, 2009 7:18 pm
Location: Jurien Bay, W.A.

VS V6 Series 1 O2 4-wire earth issues ?

Postby OZ38 » Tue Aug 29, 2017 11:05 am

I had a search around but did not find it.
But I am sure you guys would have discussed the VS V6 Series 1 Commodores 4-wire O2 sensors heater earthing issues ?

Is it really a known problem from Holden ? I was reading a how to on JC to splice into the ECU pin out earths & ground to the body.
Has anyone found where the original problem occurs in the loom ?

Cheers

Posts: 184
Joined: Thu May 03, 2012 10:50 pm
Location: Castlemaine, Vic

Re: VS V6 Series 1 O2 4-wire earth issues ?

Postby pman92 » Tue Aug 29, 2017 2:00 pm

I'm 90% sure the real problem is usually one of the earth points on the engine (I think the one at the driver side front on drive belt tensioner?)
The best solution is to splice in and add a good earth directly to the O2 sensor wiring I would say

User avatar
Posts: 3772
Joined: Mon Jan 04, 2010 10:23 am

Re: VS V6 Series 1 O2 4-wire earth issues ?

Postby The1 » Tue Aug 29, 2017 9:38 pm

this was it i believe.
Attachments
Injectronics_Technical_Bulletin_40 VS O2 Sensor fix.pdf
(240.9 KiB) Downloaded 18 times

Posts: 2008
Joined: Thu Apr 09, 2009 12:31 pm

Re: VS V6 Series 1 O2 4-wire earth issues ?

Postby immortality » Wed Aug 30, 2017 9:15 am

The quick fix was to cut the heater wire for the sensor that was playing up.

The wiring diagram shows that one of the O2 sensor wiring looms has a link between the sensor and heater earths. What I did on our old VS was to splice both heater earths directly to the engine which seemed to do the trick. I think I tried cleaning all the earth points but did not see much improvement.

Posts: 147
Joined: Wed Jul 01, 2009 7:18 pm
Location: Jurien Bay, W.A.

Re: VS V6 Series 1 O2 4-wire earth issues ?

Postby OZ38 » Sat Sep 09, 2017 4:33 am

immortality wrote:The quick fix was to cut the heater wire for the sensor that was playing up.

The wiring diagram shows that one of the O2 sensor wiring looms has a link between the sensor and heater earths. What I did on our old VS was to splice both heater earths directly to the engine which seemed to do the trick. I think I tried cleaning all the earth points but did not see much improvement.

My old VS always smells like it is running very rich (especially at idle). I will try cleaning those earths but if I feel there is no change I might try splicing into the O2 heater earths like you did.

Posts: 2008
Joined: Thu Apr 09, 2009 12:31 pm

Re: VS V6 Series 1 O2 4-wire earth issues ?

Postby immortality » Sat Sep 09, 2017 7:27 am

I made up a small patch loom using a couple of old O2 sensors and a couple of plugs from another loom I raided at the wreckers so that I didn't have to cut the actual loom.

Fitting new O2 sensors, patching the loom and then fitting some later style 777 injectors was the best thing I ever did for fuel economy on the old VS.

Posts: 147
Joined: Wed Jul 01, 2009 7:18 pm
Location: Jurien Bay, W.A.

Re: VS V6 Series 1 O2 4-wire earth issues ?

Postby OZ38 » Sun Sep 10, 2017 4:14 am

immortality wrote:I made up a small patch loom using a couple of old O2 sensors and a couple of plugs from another loom I raided at the wreckers so that I didn't have to cut the actual loom.

Fitting new O2 sensors, patching the loom and then fitting some later style 777 injectors was the best thing I ever did for fuel economy on the old VS.

Can you draw how you did the patch loom ?
I intend to change the O2 sensors so would end up with two I can bastardise.

Posts: 2008
Joined: Thu Apr 09, 2009 12:31 pm

Re: VS V6 Series 1 O2 4-wire earth issues ?

Postby immortality » Sun Sep 17, 2017 3:02 pm

Sorry, completely forgot about this. I don't have a wiring diagram, the only thing I still have is a pick of the completed patch loom.
O2 interceptor wiring plug.jpg
O2 interceptor wiring plug.jpg (42.39 KiB) Viewed 81 times


This is the last version I made. I fitted one in each side and extended the earths for both sensors so they were earthed at the same location on the block and then wired the heater earths together on a different part of the block.

The unused tails are wrapped up inside the loom to make it look tidy but they are isolated and not connected.

Posts: 147
Joined: Wed Jul 01, 2009 7:18 pm
Location: Jurien Bay, W.A.

Re: VS V6 Series 1 O2 4-wire earth issues ?

Postby OZ38 » Mon Sep 25, 2017 4:18 am

Thanks for that.

Return to Wiring

Who is online

Users browsing this forum: No registered users and 1 guest