VX v6 wagon code 49

For non EFI mechanical discussion
Posts: 219
Joined: Mon Aug 19, 2019 12:32 pm
Location: Christchurch, NZ

VX v6 wagon code 49

Postby Pete30nz » Sat Oct 01, 2022 4:20 pm

Hi there

A mate of a mates wagon has been playing up for around a year.

Caught up with him a few nights ago, plugged in with tunerpro and aldl, got code 49.

So I suggested replacing the crank angle sensor. We replaced it today.

Also we cleaned the cam sensor.

While we were at it, checked the dfi loom plug, cleaned it with contact cleaner, and looked at the terminals plugs and they looked good, no corrosion. One spot doesn't have a pin.



The car was playing up once we went to start the engine. It would turn over some times. When it would turn over it wanted to fire. And then at times it would start, but not idle.

Some times it would start and idle

Before I left today, my last error check showed up code 48.

Any thought appreciated
Cheers

Posts: 1198
Joined: Sun Mar 15, 2009 10:20 am
Location: Geelong, VIC

Re: VX v6 wagon code 49

Postby yoda69 » Sat Oct 01, 2022 5:06 pm

Sounds like a faulty cam angle sensor now.
Check wiring that it is connected and wiring not damaged after being removed and refitted.
Also check fitted correctly.

Posts: 219
Joined: Mon Aug 19, 2019 12:32 pm
Location: Christchurch, NZ

Re: VX v6 wagon code 49

Postby Pete30nz » Sat Oct 01, 2022 7:22 pm

Hi there, thanks for the reply.

I've asked him how the car is going tonight. After checking fuses he had found a few loose-ish ones, and pushed them home firm. He'd taken it for a couple of drives this evening, and it seems to be going good.

Tomorrow if he's home ill go plug in, and check the system, see if I can see any thing - Aldl and tunerpro.

Cheers

Posts: 219
Joined: Mon Aug 19, 2019 12:32 pm
Location: Christchurch, NZ

Re: VX v6 wagon code 49

Postby Pete30nz » Sun Oct 02, 2022 2:59 pm

Afternoon

I went to the VX v6 today, and plugged in to see if there were any error codes logged. I was using the VX_V6_$BD_Enhanced_v0.9e.zip, adx and xdf. I also tried out of curiosity these two xdf files: VXV6_BD A v1.33.xdf and VXV6_BD B v1.33.xdf
While in the dtc error code screen, i saw lots of error codes flashing up and off, random ones.

what i cant remember is, if blm reset was in the drop down menu, or if clear pcm dtc was selected. would that matter though?

I'm starting to think i had selected some thing wrong. When selecting different adx or xdf's should i be closing tunerpro and then restarting it after selecting a new one?

cheers

Site Admin
User avatar
Posts: 7344
Joined: Sat Feb 28, 2009 8:34 pm

Re: VX v6 wagon code 49

Postby antus » Sun Oct 02, 2022 8:44 pm

no you dont have to restart tunerpro but you should capture new data with the new file which happens to how that is described in the adx. Dont mix and match XDFs, find out which one matches your code and stick with that.
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

Posts: 219
Joined: Mon Aug 19, 2019 12:32 pm
Location: Christchurch, NZ

Re: VX v6 wagon code 49

Postby Pete30nz » Mon Oct 03, 2022 9:12 am

Ok, thanks for the reply.

If the adx doesn't flash on and off error codes, it should match the vehicle? As this vehicle is standard as.

Posts: 1198
Joined: Sun Mar 15, 2009 10:20 am
Location: Geelong, VIC

Re: VX v6 wagon code 49

Postby yoda69 » Mon Oct 03, 2022 11:29 am

If it’s flashing on and off data check that the Echo settings in the ADX are correct for your ALDL cable.
If unsure change and try to connect again.

Posts: 219
Joined: Mon Aug 19, 2019 12:32 pm
Location: Christchurch, NZ

Re: VX v6 wagon code 49

Postby Pete30nz » Mon Oct 03, 2022 12:11 pm

Thanks guys, and continued ideas are welcome.
I'll have to wait until I go over there next.

Cheers

Return to Engine/Transmision Mechanical

Who is online

Users browsing this forum: No registered users and 1 guest