03-07 Truck Instrument Cluster Firmware

They go by many names, P01, P59, VPW, '0411 etc . Circa 1999 to 2006. All VPW OBD2 PCMs.
Site Admin
User avatar
Posts: 6456
Joined: Sat Feb 28, 2009 8:34 pm

Re: 03-07 Truck Instrument Cluster Firmware

Postby antus » Thu Oct 22, 2020 10:31 am

Nice one!
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

Posts: 85
Joined: Wed Apr 11, 2018 8:50 am

Re: 03-07 Truck Instrument Cluster Firmware

Postby bubba2533 » Fri Oct 23, 2020 1:02 am

This is awesome! Now I want to put one of these clusters in my S10. I'll have to grab one from the junkyard next time I'm there.

Posts: 28
Joined: Fri Jan 24, 2020 12:44 pm

Re: 03-07 Truck Instrument Cluster Firmware

Postby Fixed until broken » Fri Oct 23, 2020 3:45 am

Thanks guys.

bubba2533 wrote:This is awesome! Now I want to put one of these clusters in my S10. I'll have to grab one from the junkyard next time I'm there.

Make sure its 03 or 04 they are the only 2 with that Microcontroller the 05, 06/07 ones have a different MCU. Thats my next big project.

Posts: 85
Joined: Wed Apr 11, 2018 8:50 am

Re: 03-07 Truck Instrument Cluster Firmware

Postby bubba2533 » Fri Oct 23, 2020 4:59 am

Fixed until broken wrote:Thanks guys.

bubba2533 wrote:This is awesome! Now I want to put one of these clusters in my S10. I'll have to grab one from the junkyard next time I'm there.

Make sure its 03 or 04 they are the only 2 with that Microcontroller the 05, 06/07 ones have a different MCU. Thats my next big project.


Is there any difference between them that I should wait for the 05, 06/07 one? Or is it just internal differences?

Posts: 28
Joined: Fri Jan 24, 2020 12:44 pm

Re: 03-07 Truck Instrument Cluster Firmware

Postby Fixed until broken » Fri Oct 23, 2020 9:12 am

bubba2533 wrote:Is there any difference between them that I should wait for the 05, 06/07 one? Or is it just internal differences?

Mostly just component differences internal. Wiring is all the same. 06/07 is looking for a Class 2 signal about the charging system that will cause them to light up a battery light all the time if installed in a 03/04 truck I am not sure if it will do it in an 05.

Its about the same board though just different MCU with different firmware on the MCU. Same transceiver, same EEprom ( a couple of bytes are different in the bin), same VFD driver. It does have a different voltage regulator.

Posts: 3
Joined: Wed Aug 09, 2017 2:29 am

Re: 03-07 Truck Instrument Cluster Firmware

Postby JandJSpeedShop » Thu Jan 07, 2021 4:28 pm

I have a bunch of these instrument cluster boards laying around. Interesting work.

Posts: 3
Joined: Mon Nov 16, 2020 9:20 am

Re: 03-07 Truck Instrument Cluster Firmware

Postby BigBadSubaru » Thu Jan 14, 2021 3:43 pm

Does the EEPROM portion also contain parameters such as if it's a truck or SUV cluster, etc? Reason I ask is I've got an 03 Suburban that has a truck cluster in it, and in addition to it lacking the transmission temp gauge, since the Suburban uses a hydroboost system for the brake booster instead of a vacuum booster, the cluster throws a "Service brake booster" message at every startup. It's also got the wrong mileage displayed on it so I may end up just saying F it and sending it off to get reprogrammed but being the nerdy sort I'd rather figure out how to do it myself if I can :-P (And if I can figure that stuff out, I can make a few bucks on the side refurbishing clusters)

Previous

Return to GM LS1 512Kbyte and 1Mbyte

Who is online

Users browsing this forum: No registered users and 2 guests