First time tuning. Need some help.

They go by many names, P01, P59, VPW, '0411 etc . Circa 1999 to 2006. All VPW OBD2 PCMs.
Posts: 12
Joined: Thu Sep 17, 2020 2:51 pm

First time tuning. Need some help.

Postby vvise » Thu Sep 17, 2020 3:23 pm

Hey everyone thanks for taking the time.

I have a PCM out of a 2005 van 2500 (Service No. 12589462)
I swapped the motor from said donor van into a 280Z and got the car ready to start. It would start for a split second and cut out. OBD2 scanner indicated VATS was enabled.

I did the following on a bench harness.
I have an OBDLinkMX+ and used LS Droid to pull the .bin
I tried to get an XDF on the Gearhead forums but my account is still waiting for an approval. I instead found one here:
https://github.com/BoredTruckOwner/LS_B ... es/P59_1Mb
The 12589462 is even mentioned in the OS_Features.txt

I opened it up in TunerPro and changed the Vats feature from 0 to 2. Saved. Then used LS Driod to upload it back into the ECM. Everything confirmed and validated.

When I powered the car back up a few things seemed strange, the fuel pump didn't prime and I heard some clicking coming from the engine that wasn't there before (unclear if relays/spark plugs/injectors?). And when I crank I no longer get any start at all. There appears to be no ignition but I didn't confirm.

Going back I loaded the original .bin back in TunerPro to take a closer look, this time digging more into some of the settings and many of them don't appear to make sense (Engine Type 72, Number of Cylinders 0). I attached a screenshot of a few.
tunerpro huh.jpg


I decided to go back and flash the original .bin back onto the PCM to see if I can at least go back to before but LS Driod will no longer sync the bluetooth connection. The default OBDLink andriod app still connects.

Any help is appreciated, what did i do? Have I softlocked myself out? I can attach .bin if someone would like to see it.

Thanks in advance.

Site Admin
User avatar
Posts: 6273
Joined: Sat Feb 28, 2009 8:34 pm

Re: First time tuning. Need some help.

Postby antus » Thu Sep 17, 2020 5:08 pm

It looks to me like you dont have the right XDF for the OS. You probably have changed something which has had unintended side effects and might be crashing the PCM. You will probably need to open the pcm and ground the pin which triggers recovery mode, and use that to be able to flash the original bin back in.

Then you'll need to identify what OS the bin is and either get the right XDF, or put a supported OS on the PCM and work from there. Since its a transplant that should be fine. Can you upload your original bin here?
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

Posts: 12
Joined: Thu Sep 17, 2020 2:51 pm

Re: First time tuning. Need some help.

Postby vvise » Thu Sep 17, 2020 10:31 pm

2005Van.bin
(1 MiB) Downloaded 7 times

Posts: 698
Joined: Sat Dec 15, 2018 7:38 am

Re: First time tuning. Need some help.

Postby Gampy » Thu Sep 17, 2020 11:39 pm

As Antus suspected, wrong XDF for the OS ...

In the title bar of TunerPro it says you are using the XDF for OsID: 125 87 603

The bin file you attached (2005Van.bin) is OsID: 125 92 618

That is a fail ... You MUST use the proper XDF for the OsID.

That I know of there is NO XDF for OsID: 12592618.

It would be best to replace OsID: 12592618 with a supported OS like OsID: 12587603.

Code: Select all
   Filename ...........................: 2005Van.bin
     Year .............................:
     Make .............................:
     Model ............................:
     Engine ...........................:
     Transmission .....................:
     Service Number ...................: 12589462
     Hardware Number ..................: 12589161
     Operating System Number (OsID)....: 12592618
     Broadcast Code ...................: YHZP
     Calibration Number ...............: 12591721
     System Calibration Number ........: 12592176
     Engine Calibration Number ........: 12592169
     Engine Diagnostics Number ........: 12583946
     Transmission Calibration Number ..: 12584014
     Transmission Diagnostics Number ..: 12586728
     Fuel System Calibration Number ...: 12593361
     Speedometer Calibration Number ...: 12584037
     Serial Number ....................: 0MA016NV4218
     Vehicle Identification Number ....: 1GCFG25T751110131
The VIN is invalid so I suspect it's a modified bin ...
Temporary is a permanent problem!

User avatar
Posts: 212
Joined: Tue Dec 17, 2019 3:27 am

Re: First time tuning. Need some help.

Postby joukoy » Fri Sep 18, 2020 12:27 am

Gampy wrote:That I know of there is NO XDF for OsID: 12592618.


Not complete, but:
http://www.gearhead-efi.com/Fuel-Inject ... 1577143868

http://www.gearhead-efi.com/Fuel-Inject ... t=12592618

Posts: 12
Joined: Thu Sep 17, 2020 2:51 pm

Re: First time tuning. Need some help.

Postby vvise » Fri Sep 18, 2020 12:32 am

Gampy wrote:As Antus suspected, wrong XDF for the OS ...

In the title bar of TunerPro it says you are using the XDF for OsID: 125 87 603

The bin file you attached (2005Van.bin) is OsID: 125 92 618

That is a fail ... You MUST use the proper XDF for the OsID.

That I know of there is NO XDF for OsID: 12592618.

It would be best to replace OsID: 12592618 with a supported OS like OsID: 12587603.
Thanks for the help, I also couldn't find an XDF for OsID: 12592618 but browsing a number of sources I was led to believe the 603 was universal for P59 PCMs.

Gampy wrote:The VIN is invalid so I suspect it's a modified bin ...
this is surprising, it was a fleet van so I'm surprised someone was messing with it.

antus wrote:You will probably need to open the pcm and ground the pin which triggers recovery mode, and use that to be able to flash the original bin back in.

Then you'll need to identify what OS the bin is and either get the right XDF, or put a supported OS on the PCM and work from there. Since its a transplant that should be fine. Can you upload your original bin here?
I'll give the ground pin recovery method a try tonight to see if i can recover the original bin. Hopefully at that point it's booting normally and I'll try and do a full flash for a 603 and a donor .bin from the repository.

joukoy wrote:
Gampy wrote:That I know of there is NO XDF for OsID: 12592618.


Not complete, but:
http://www.gearhead-efi.com/Fuel-Inject ... 1577143868

http://www.gearhead-efi.com/Fuel-Inject ... t=12592618
Unfortunately I'm not able to get anything from Gearhead without a moderator approving my account.

Posts: 698
Joined: Sat Dec 15, 2018 7:38 am

Re: First time tuning. Need some help.

Postby Gampy » Fri Sep 18, 2020 1:16 am

Thanks Joukoy,

I do not believe @ColPaul minds if it's posted here ...

Please see here for information about this XDF, it is incomplete, use at your own risk!
Paul's 12592618 1Mb PCM - 2005 ALPHA.xdf
(27.53 KiB) Downloaded 3 times

vvise,
Are you saying that bin (2005Van.bin) is the original (unmodified by you) file off that PCM ??
Temporary is a permanent problem!

Posts: 12
Joined: Thu Sep 17, 2020 2:51 pm

Re: First time tuning. Need some help.

Postby vvise » Fri Sep 18, 2020 1:17 am

Gampy wrote:vvise,
Are you saying that bin (2005Van.bin) is the original (unmodified by you) file off that PCM ??

correct.

The VIN looks okay here: http://www.free-vin-decoder.com/vin/1GCFG25T751110131
lines up with what I saw in the donor.
Last edited by vvise on Fri Sep 18, 2020 1:30 am, edited 1 time in total.

Posts: 698
Joined: Sat Dec 15, 2018 7:38 am

Re: First time tuning. Need some help.

Postby Gampy » Fri Sep 18, 2020 1:24 am

Interesting.

Thank you!
Temporary is a permanent problem!

Posts: 243
Joined: Mon Mar 09, 2020 4:35 pm
Location: California

Re: First time tuning. Need some help.

Postby In-Tech » Fri Sep 18, 2020 1:25 am

There doesn't seem to be anything wrong with that vin according to this website: https://driving-tests.org/vin-decoder/

Next

Return to GM LS1 512Kbyte and 1Mbyte

Who is online

Users browsing this forum: No registered users and 4 guests