1227165 ECU Questions

American GM ECUs and PCMs
Posts: 50
Joined: Sat Nov 25, 2017 8:13 pm

Re: 1227165 ECU Questions

Postby K1ng0011 » Fri Jun 22, 2018 3:07 pm

Replaced the coil this afternoon with a known working one so that is not it. Could be the ignition module. I would have terrible luck though it is basically new. My ECU and tac both are seeing rpm from the module though. I don't know if it helps but it is possible to keep it running by holding the gas pedal. Which is weird it's like the AE is keeping it running or the extra air is. I replaced the iac so I don't think it's air.

User avatar
Posts: 4609
Joined: Sat Feb 28, 2009 8:38 pm
Location: Wellington NZ

Re: 1227165 ECU Questions

Postby delcowizzid » Fri Jun 22, 2018 4:14 pm

Oh so its just stalling from not enough air not actually switching off I'll look at the log tonight
If Its Got Gas Or Ass Count Me In.if it cant be fixed with a hammer you have an electrical problem

Posts: 50
Joined: Sat Nov 25, 2017 8:13 pm

Re: 1227165 ECU Questions

Postby K1ng0011 » Sat Jun 23, 2018 6:32 am

So I replaced the ignition module which had no effect it still dies after about ten seconds of running. I unplugged the iac and that has no effect at all. I tried adjusting the base timing with no effect. I went into the bin and changed from 23lb injectors to 19lb to try and richen up the mixture with no effect still dies.

Posts: 286
Joined: Thu May 03, 2012 10:50 pm
Location: Castlemaine, Vic

Re: 1227165 ECU Questions

Postby pman92 » Sat Jun 23, 2018 7:22 am

Check fuel pressure

Posts: 1135
Joined: Sat Aug 06, 2011 7:58 am
Location: Padstow NSW

Re: 1227165 ECU Questions

Postby Charlescrown » Sat Jun 23, 2018 7:56 am

How bazaar. I left a comment yesterday and now it's gone? I agree check the fuel pressure. You can see as it starts to cut out the ECU is making a desperate attempt to add fuel going from 4.6ms to over 16.

Posts: 3082
Joined: Mon Aug 02, 2010 6:35 pm

Re: 1227165 ECU Questions

Postby Dylan » Sat Jun 23, 2018 8:41 am

Over fuelling can read as lean on a wideband, which we're seeing lean AFR. Raw fuel out the exhaust will read as air.

Posts: 50
Joined: Sat Nov 25, 2017 8:13 pm

Re: 1227165 ECU Questions

Postby K1ng0011 » Sun Jun 24, 2018 3:40 am

Alright I will look into the fuel pressure to see if that is an issue. I will let you know what I find. If there is an issue it would probably be the fuel pressure regulator or a power/ground issues. I have to go on a trip I will be back in about a two weeks and check things out and let you kniow what I find.

User avatar
Posts: 4609
Joined: Sat Feb 28, 2009 8:38 pm
Location: Wellington NZ

Re: 1227165 ECU Questions

Postby delcowizzid » Mon Jun 25, 2018 12:13 am

Got a chance to look at the log does look like the pumps died and its just real lean .first start at 14 then as the ecu leans out it just trends up till it shuts off
If Its Got Gas Or Ass Count Me In.if it cant be fixed with a hammer you have an electrical problem

Posts: 50
Joined: Sat Nov 25, 2017 8:13 pm

Re: 1227165 ECU Questions

Postby K1ng0011 » Sun Jul 08, 2018 6:00 am

I am back from my trip and I figured out what the issue was. The injectors that I have that I mentioned previously in the thread. They are a little bit shorter than a stock injector that would have came in a 80s camaro where I got my intake from. Two of the injectors had slid a little out of the fuel rail and were in the intake further than the others. They did not slide out of the fuel rail completely and I had no fuel leaks. However it must have been enough to reduce the fuel pressure to keep it from running. The moment I pushed the injectors back up into the fuel rail it starts and will keep running now. I have two options to prevent this from occurring again. There are clips I can get to prevent the injectors from sliding out of the fuel rail or I can buy a correct set of injectors.

Posts: 50
Joined: Sat Nov 25, 2017 8:13 pm

Re: 1227165 ECU Questions

Postby K1ng0011 » Tue Jul 10, 2018 6:19 am

I ordered a set of clips for the fuel injectors to hold them in the rail. They should be here later this week. Once I got them and get everything put back together I will report if the issue returns or is fixed at that point.

PreviousNext

Return to US GM ECUs

Who is online

Users browsing this forum: No registered users and 3 guests