1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

American Delco GM ECUs and PCMs, ALDL, OBD 1.5.
User avatar
Posts: 4988
Joined: Sun Mar 01, 2009 2:54 pm
Location: Perth, WA

Re: 1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

Postby VL400 » Wed Apr 12, 2017 7:04 am


Posts: 30
Joined: Mon Apr 03, 2017 2:33 am

Re: 1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

Postby Mark_ZZ3 » Wed Apr 12, 2017 10:22 am

VL400 wrote:
Dazza92VP wrote:There are flags in the flashtool where you setup the axis config. One is called "Invert Output Duty Cycle" so you can have 0 off and 100 fully on. And another is called "Active only with Engine Run".

For the TPS thing may need to check the config is correct. By default its using TPS and RPM. Maybe the cal/bin wasnt saved before exiting the flashtool editor?


Where in the XDF is this located? Is there a flag I can set to flip this one way or the other?

Mark.

User avatar
Posts: 9759
Joined: Sat Feb 28, 2009 9:05 pm
Location: Tenambit, NSW

Re: 1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

Postby Holden202T » Wed Apr 12, 2017 10:25 am

that functionality is in the OSE Flashtool, under flexible output editor. viewtopic.php?f=3&t=82

Posts: 30
Joined: Mon Apr 03, 2017 2:33 am

Re: 1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

Postby Mark_ZZ3 » Wed Apr 12, 2017 11:29 am

Holden202T wrote:that functionality is in the OSE Flashtool, under flexible output editor. viewtopic.php?f=3&t=82


Ok. I am not using the flashtool. I edit the BIN using the XDF. And then write the EEPROM. Install into the '165. It's rather crude, but that is what I have to work with.

I assumed the XDF had all the parameters. So the flashtool will change yet a few more parameters than what is available in the XDF?

Mark.

Posts: 30
Joined: Mon Apr 03, 2017 2:33 am

Re: 1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

Postby Mark_ZZ3 » Wed Apr 12, 2017 11:45 am

Found it ... now testing.

User avatar
Posts: 9759
Joined: Sat Feb 28, 2009 9:05 pm
Location: Tenambit, NSW

Re: 1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

Postby Holden202T » Wed Apr 12, 2017 2:22 pm

the flashtool flexible editor changes other parts of the code to make it work properly, only calibration data is in the XDF.

when you update the flexible tables axis or settings the flashtool will ask you to select an XDF to update, once you do that and save it, you will then find in the XDF it will populate the tables with the axis you has setup, the table data can then be put into it through tunerpro .....

so for my own car I have two flex tables setup as per below, flex table A is for controlling an electric water pump, and flex b is for activating a second fuel pump only over 2750rpm and over 106kpa manifold pressure

flex tables.jpg
flex tables.jpg (626.28 KiB) Viewed 3142 times

and here you can see what sort of settings you need to make it work .... eg. to control a relay on/off you tick the digital on/off option, but then flex a is a PWM controller so not used in this manner.

flex tables2.jpg
flex tables2.jpg (138.39 KiB) Viewed 3142 times

Posts: 30
Joined: Mon Apr 03, 2017 2:33 am

Re: 1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

Postby Mark_ZZ3 » Wed Apr 12, 2017 2:52 pm

Hmm. Well not much luck with the Flex tables. I tried setting Flex Table 2 to control the relay. I can get it to turn on, but not off. I've set the X and Y axis a few different ways. No luck. The logging shows the boost goes into the range and then outside the range I defined, and the cells switch from 0 to 99.61, and relay stayed energized. So I am still missing something.

So I tried the Flashtool. I changed Flex Table 2 to MAP vs MAP. Keep it simple. It looks the same as what I did in the XDF. So I redid the XDF from the flashtool. It still looks the same. I will have to do a road test and see if that is the difference needed. Maybe I can add to the XDF for the check boxes on the Flashtool to pick Relay or inverted values?

Overall .. the testing was good tonight. My '165 started to go bad. Had to swap in a spare. Really weird, but I suppose too much handling and swaping proms.

The engine needs more fuel ... I think I maxed out the settings. Boost spools up to 6 psi. Pulls for the first 3 psi, and then gets slower. If you open throttle 100%, it actually feels slower. O2 shows it's still OK, but I think it's time to invest in a wide band and see what's happening. Also time to upgrade fuel pump and injectors ... or at least start looking for something to replace them.

For the time being ... I'll continue to work on the boost controller "thing". I'd like to know we have a limit setup.

Mark.

Posts: 30
Joined: Mon Apr 03, 2017 2:33 am

Re: 1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

Postby Mark_ZZ3 » Wed Apr 12, 2017 2:55 pm

@Holden202T

I will double check what I did ... well actually I will just re-do the flex tables and see what they do. I swear I did them like you did, but I can't get the relay to turn off. I'll try a lower setting to see if I can get it to go on and off. I suspect this is something simple and I am overlooking it.

Mark.

User avatar
Posts: 9759
Joined: Sat Feb 28, 2009 9:05 pm
Location: Tenambit, NSW

Re: 1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

Postby Holden202T » Wed Apr 12, 2017 4:12 pm

post your bin and I can have a look....

just so you know, if the value goes outside the table it will use the last cell value, so in the case of my relay control for the second fuel pump, any thing about the max map and rpm axis on the tables it will stay on till it gets back below those values.

also how do you have the relay wired up to the flex output ?

Posts: 30
Joined: Mon Apr 03, 2017 2:33 am

Re: 1227165 Running 12P for a GM 2.5L Iron Duke with Turbo

Postby Mark_ZZ3 » Thu Apr 13, 2017 12:53 pm

here is my last attempt at the Flex Table B:

Image

The relay comes on as soon as the engine is running. As the log moves into the 140 range, it stays on. Now consider this is after a number of different versions. I had moved the KPA values, tried an RPM vs KPA table, and so forth. I had one version where the KPA was low and I could see the relay go on, but not off from KPA, only RPM. So ... I've missed something.

I've now taken the flash tool and told it what I want the Flex Table B to be. then edited the XDF. So I should have all the steps followed ... but it still did not seem to work.

(Looking at the HEX differences, there is usually only one byte that changes if you pick different options ... so curious if you could just map a flag in the XDF instead?).

I added the latest BIN I am working with (consider this is just a prototype given the base fuel system we have ... still lots of work to do. First was to get the 2 BAR working).

Mark.
Attachments
Alex 12P 2 Bar 1.0.bin
(32 KiB) Downloaded 107 times

PreviousNext

Return to US ALDL ECUs

Who is online

Users browsing this forum: No registered users and 1 guest