Cant Write To My NVRAM

Tuning The Delco In Realtime
Posts: 3146
Joined: Mon Aug 02, 2010 6:35 pm

Cant Write To My NVRAM

Postby Dylan » Tue May 06, 2014 8:35 pm

Im having trouble writing to my NVRAM. Car is my VR Commdore V8.
I have a modified 808 with one of VL400's NVRAM's, SXR boards and one of his USB Vehichle interfaces (connected under steering column)
Last weekend i used flash tool to do a write cal a few times as i was working on a mates tune. This is the first time ive had my gear on another vehichle. Today i fitted my ecu back to my car and went to write cal (flash my tune back in) and got errors.

Flash tool connects, tuner pro connects and i can read sensor data etc. I can even do a get bin with flash tool. But i cant even write the same bin back, or just the cal. Im really at a loss. I tried going to bank B which has never been used before, same deal.
I also tried tuner pro to write but errors aswell.
Im using $12P V111. And Flash Tool V 1.45 with preferences set to VR in vehichle and USB ALDL for interface.

Is there something ive missed here? I done write cal plenty of times with this set up on the same car without trouble.
Last edited by Dylan on Tue May 06, 2014 8:40 pm, edited 1 time in total.

Posts: 3146
Joined: Mon Aug 02, 2010 6:35 pm

Re: Cant Write To My NVRAM

Postby Dylan » Tue May 06, 2014 8:36 pm

When i first connect to ecm this is what comes up in the window

8:35:37 PM FlashTool Version 0.1.4.5 Program Loading...
8:35:37 PM Program Ready
8:35:41 PM Starting Connect To Device...
8:35:41 PM COM4 Open
8:35:41 PM Check if Logger V2 in partial passthrough mode
8:35:41 PM Not a logger V2
8:35:41 PM Not Detecting HeartBeat
8:35:41 PM Waiting For 50 mS Of Silence
8:35:41 PM Silence Detected, waited 50mS
8:35:41 PM Requesting Chatter To Be Disabled For Device BD
8:35:41 PM Chatter Disabled
8:35:41 PM Waiting For 50 mS Of Silence
8:35:41 PM Silence Detected, waited 50mS
8:35:41 PM Requesting Chatter To Be Disabled For Device F4
8:35:41 PM Chatter Disabled
8:35:41 PM Searching For OSE Device...
8:35:41 PM Searching For ECM...Attempt 1...
8:35:41 PM Request Sent
8:35:41 PM Device Found, Identifying...
8:35:41 PM Waiting For 50 mS Of Silence
8:35:41 PM Silence Detected, waited 50mS
8:35:41 PM Requesting Chatter To Be Enabled For Device F4
8:35:41 PM Chatter Enabled
8:35:41 PM Waiting For 50 mS Of Silence
8:35:41 PM Silence Detected, waited 50mS
8:35:41 PM Requesting Chatter To Be Enabled For Device BD
8:35:42 PM No Response
8:35:42 PM Waiting For 50 mS Of Silence
8:35:42 PM Silence Detected, waited 50mS
8:35:42 PM Requesting Chatter To Be Enabled For Device BD
8:35:42 PM No Response
8:35:42 PM Waiting For 50 mS Of Silence
8:35:42 PM Silence Detected, waited 50mS
8:35:42 PM Requesting Chatter To Be Enabled For Device BD
8:35:42 PM No Response
8:35:42 PM Waiting For 50 mS Of Silence
8:35:42 PM Silence Detected, waited 50mS
8:35:42 PM Requesting Chatter To Be Enabled For Device BD
8:35:43 PM No Response
8:35:43 PM Waiting For 50 mS Of Silence
8:35:43 PM Silence Detected, waited 50mS
8:35:43 PM Requesting Chatter To Be Enabled For Device BD
8:35:43 PM No Response
8:35:43 PM Waiting For 50 mS Of Silence
8:35:43 PM Silence Detected, waited 50mS
8:35:43 PM Requesting Chatter To Be Enabled For Device BD
8:35:43 PM No Response
8:35:43 PM Waiting For 50 mS Of Silence
8:35:43 PM Silence Detected, waited 50mS
8:35:43 PM Requesting Chatter To Be Enabled For Device BD
8:35:44 PM No Response
8:35:44 PM Waiting For 50 mS Of Silence
8:35:44 PM Silence Detected, waited 50mS
8:35:44 PM Requesting Chatter To Be Enabled For Device BD
8:35:44 PM No Response
8:35:44 PM Waiting For 50 mS Of Silence
8:35:44 PM Silence Detected, waited 50mS
8:35:44 PM Requesting Chatter To Be Enabled For Device BD
8:35:44 PM No Response
8:35:44 PM Waiting For 50 mS Of Silence
8:35:44 PM Silence Detected, waited 50mS
8:35:44 PM Requesting Chatter To Be Enabled For Device BD
8:35:45 PM No Response
8:35:45 PM Found $12 OSE Pro ECM, Version: 01-01-01
8:35:45 PM COM4 closed


I can do a succesfull get bin after this
Last edited by Dylan on Tue May 06, 2014 8:45 pm, edited 1 time in total.

Posts: 3146
Joined: Mon Aug 02, 2010 6:35 pm

Re: Cant Write To My NVRAM

Postby Dylan » Tue May 06, 2014 8:38 pm

When i try to do a write cal. I select the bin that i saved after doing a get bin.
I opened that bin and it says its version 111. Thats all ive ever used anyway.


8:37:07 PM Selected Filename: C:\Users\Dylan\Tuner Pro RT\getbindylan06052014.bin
8:37:07 PM File Size Is 32768 Bytes
8:37:07 PM File Size As Expected, Got Entire Bin
8:37:07 PM Writing Calibration...
8:37:07 PM Validating File Against Connected Device...
8:37:07 PM Selected Device File OSE12Pro Matches Connected Device OSE12Pro
8:37:07 PM Selected File Version 01-01-01 Matches Connected Device Version 01-01-01
8:37:07 PM File Validated
8:37:07 PM Not Detecting HeartBeat
8:37:07 PM COM4 Open
8:37:07 PM Waiting For 50 mS Of Silence
8:37:07 PM Silence Detected, waited 50mS
8:37:07 PM Requesting Chatter To Be Disabled For Device BD
8:37:07 PM Chatter Disabled
8:37:07 PM Waiting For 50 mS Of Silence
8:37:07 PM Silence Detected, waited 50mS
8:37:07 PM Requesting Chatter To Be Disabled For Device F4
8:37:07 PM Chatter Disabled
8:37:07 PM Writing In High-Speed Mode
8:37:07 PM Writing 128 Bytes To Address Starting At $8000
8:37:07 PM No Response, Re-Sending The Write Request
8:37:07 PM Writing 128 Bytes To Address Starting At $8000
8:37:08 PM No Response, Re-Sending The Write Request
8:37:08 PM Writing 128 Bytes To Address Starting At $8000
8:37:08 PM No Response, Re-Sending The Write Request
8:37:08 PM Writing 128 Bytes To Address Starting At $8000
8:37:09 PM No Response, Re-Sending The Write Request
8:37:09 PM Writing 128 Bytes To Address Starting At $8000
8:37:09 PM No Response, Re-Sending The Write Request
8:37:09 PM Too Many Re-Tries, Switching To Normal Mode
8:37:09 PM Writing 8 Bytes To Address Starting At $8000
8:37:09 PM No Response, Re-Sending The Write Request
8:37:09 PM Writing 8 Bytes To Address Starting At $8000
8:37:10 PM No Response, Re-Sending The Write Request
8:37:10 PM Writing 8 Bytes To Address Starting At $8000
8:37:10 PM No Response, Re-Sending The Write Request
8:37:10 PM Writing 8 Bytes To Address Starting At $8000
8:37:10 PM No Response, Re-Sending The Write Request
8:37:10 PM Writing 8 Bytes To Address Starting At $8000
8:37:11 PM No Response, Re-Sending The Write Request
8:37:11 PM Writing 8 Bytes To Address Starting At $8000
8:37:11 PM No Response, Re-Sending The Write Request
8:37:11 PM Too Many ReSends, Aborted Task
8:37:11 PM Waiting For 50 mS Of Silence
8:37:11 PM Silence Detected, waited 50mS
8:37:11 PM Requesting Chatter To Be Enabled For Device F4
8:37:11 PM Chatter Enabled
8:37:11 PM Waiting For 50 mS Of Silence
8:37:11 PM Silence Detected, waited 50mS
8:37:11 PM Requesting Chatter To Be Enabled For Device BD
8:37:11 PM No Response
8:37:11 PM Waiting For 50 mS Of Silence
8:37:11 PM Silence Detected, waited 50mS
8:37:11 PM Requesting Chatter To Be Enabled For Device BD
8:37:12 PM No Response
8:37:12 PM Waiting For 50 mS Of Silence
8:37:12 PM Silence Detected, waited 53mS
8:37:12 PM Requesting Chatter To Be Enabled For Device BD
8:37:12 PM No Response
8:37:12 PM Waiting For 50 mS Of Silence
8:37:12 PM Silence Detected, waited 50mS
8:37:12 PM Requesting Chatter To Be Enabled For Device BD
8:37:12 PM No Response
8:37:12 PM Waiting For 50 mS Of Silence
8:37:12 PM Silence Detected, waited 50mS
8:37:12 PM Requesting Chatter To Be Enabled For Device BD
8:37:13 PM No Response
8:37:13 PM Waiting For 50 mS Of Silence
8:37:13 PM Silence Detected, waited 50mS
8:37:13 PM Requesting Chatter To Be Enabled For Device BD
8:37:13 PM No Response
8:37:13 PM Waiting For 50 mS Of Silence
8:37:13 PM Silence Detected, waited 50mS
8:37:13 PM Requesting Chatter To Be Enabled For Device BD
8:37:13 PM No Response
8:37:13 PM Waiting For 50 mS Of Silence
8:37:13 PM Silence Detected, waited 50mS
8:37:13 PM Requesting Chatter To Be Enabled For Device BD
8:37:14 PM No Response
8:37:14 PM Waiting For 50 mS Of Silence
8:37:14 PM Silence Detected, waited 50mS
8:37:14 PM Requesting Chatter To Be Enabled For Device BD
8:37:14 PM No Response
8:37:14 PM Waiting For 50 mS Of Silence
8:37:14 PM Silence Detected, waited 50mS
8:37:14 PM Requesting Chatter To Be Enabled For Device BD
8:37:15 PM No Response
8:37:17 PM Calibration Write Error
8:37:17 PM COM4 Closed

Site Admin
User avatar
Posts: 5660
Joined: Sat Feb 28, 2009 8:34 pm

Re: Cant Write To My NVRAM

Postby antus » Tue May 06, 2014 9:26 pm

Has the RW (read+write) jumper fallen off?
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

Posts: 3146
Joined: Mon Aug 02, 2010 6:35 pm

Re: Cant Write To My NVRAM

Postby Dylan » Tue May 06, 2014 10:08 pm

Thanks for the reply. Its still on. Maybe something is out of place? First time it's been removed from the ecu since I got it about 12 months ago.
Attachments
20140506_220617-1.jpg
20140506_220617-1.jpg (1.23 MiB) Viewed 4167 times

User avatar
Posts: 4795
Joined: Sat Feb 28, 2009 8:38 pm
Location: Wellington NZ

Re: Cant Write To My NVRAM

Postby delcowizzid » Tue May 06, 2014 10:19 pm

has the write wire itself soldered to the ecu board come off
If Its Got Gas Or Ass Count Me In.if it cant be fixed with a hammer you have an electrical problem

Posts: 3146
Joined: Mon Aug 02, 2010 6:35 pm

Re: Cant Write To My NVRAM

Postby Dylan » Tue May 06, 2014 10:24 pm

I did check that and looks good.
Possibly software?

User avatar
Posts: 4988
Joined: Sun Mar 01, 2009 2:54 pm
Location: Perth, WA

Re: Cant Write To My NVRAM

Postby VL400 » Tue May 06, 2014 11:47 pm

The way the flashtool fails to write indicates that the ECU is in read only mode to the NVRAM (it does a test on boot), it black holes all attempts to write to it so TP/flashtool software fails. Even writing a 100% identical cal to the ECU will fail, the 12P bin checks the NVRAM status before any attempt to write data.

If you grab the 12P zip have updated the ADX "OSE_$12PV111_1BAR - Petrol with calcVE.adx" to include if the NVRAM is read only or writable. Try swapping the RW jumper with say the 8 cyl jumper. Retest if its writable then. Otherwise check the RW wire is ok.

You also need to remove the 32K jumper on the NVRAM board. That jumper should be off as you have a 128k DS1245 installed. It wont be the cause of the problem but worth fixing up.

NVRAM_RW.png
NVRAM_RW.png (27.49 KiB) Viewed 4153 times

Posts: 3146
Joined: Mon Aug 02, 2010 6:35 pm

Re: Cant Write To My NVRAM

Postby Dylan » Wed May 07, 2014 7:49 am

Thanks for the help mate. I will try the new xdf tonight. Also i will remove that jumper. Im not sure how that ended up there. Thanks again i will report back!

Posts: 3146
Joined: Mon Aug 02, 2010 6:35 pm

Re: Cant Write To My NVRAM

Postby Dylan » Wed May 07, 2014 9:07 pm

Right, The NVRAM is in read only status. How the hell have i done that? I will try different jumpers and buzz out the write wire.
Thanks for the updat adx VL400.

Next

Return to Realtime Delco Tuning

Who is online

Users browsing this forum: No registered users and 1 guest