Cold start car stalls when taking off help needed

General Tuning Questions And Discussions
User avatar
Posts: 280
Joined: Sun Oct 28, 2012 12:57 pm

Re: Cold start car stalls when taking off help needed

Postby 'quipt4it » Tue Mar 30, 2021 11:36 pm

Yes. However, do you notice the A/F ratios have less incremental changes in this table compared to the Cold Engine A/F Ratio vs Coolant Temp and MAP.
I think if the Cold Engine A/F table shows no improvement, move onto the cranking etc as mentioned.

User avatar
Posts: 280
Joined: Sun Oct 28, 2012 12:57 pm

Re: Cold start car stalls when taking off help needed

Postby 'quipt4it » Wed Mar 31, 2021 7:25 am

I also thought about Transient/ Manifold Fuel. The fuel calculation that takes fuel puddling on the port walls and runners into the total AE fuel delivered.
The fact that it takes slightly longer to start first time as compared to second...
Do you think one of the injectors may not be holding closed.
Regardless, you can look at fine tuning this also: RPM gain factor for Manifold fuel calc, and Transient - AE Gain vs Delta manifold fuel

Posts: 272
Joined: Wed May 19, 2010 2:21 pm

Re: Cold start car stalls when taking off help needed

Postby vp304 » Wed Mar 31, 2021 8:44 am

Ok so last night tried the .3 leaner of original settings for air fuel ratio when cold did not make nearly any difference still stalled

So this morning stone cold again i tried a little bit leaner again on the cold start areas

But i also leaned of the 2nd stage crank settings when cold moved all the numbers one row down to see what it would do.

Looks like the 2nd stage is working as when it started the idle was a bit fluffy rough sounded like not enough fuel for a good say 5 sec or so. When i put into drive was a little rough then stalled when i went to take off.

So far the original air fuel ratio table when cold seems to be the best :(

Injectors should be good as i had them cleaned 3000km ago when i put the motor in and have new walbro fuel pump genuine i fitted also around same time.
Attachments
167043618_818151938801066_287703267679567195_n.jpg
165785731_144916537544721_2694913404836134629_n.jpg
167063365_2825971270988120_2674277974263276285_n.jpg

User avatar
Posts: 280
Joined: Sun Oct 28, 2012 12:57 pm

Re: Cold start car stalls when taking off help needed

Postby 'quipt4it » Wed Mar 31, 2021 9:01 am

Are you sure those Cold Engine A/F R's have only been moved 0.3 from original.
If so, they should be richer, as the starting point is too lean. Try -0.2 to -0.3 in those 20 to 32 degree low map areas (from the original figures) that are showing in the 14's A/F.
To clarify, can you post the original table before you do anything else.
If nothing, then move on to the other suggestions mentioned.
Also, I have found you can move the Max Temp. for Cold Engine Table down to 32 degrees in the Run A/F Param.
You also adjusted the second stage cranking, it may not be getting to that...

Posts: 272
Joined: Wed May 19, 2010 2:21 pm

Re: Cold start car stalls when taking off help needed

Postby vp304 » Wed Mar 31, 2021 11:24 am

Here is my original starting air fuel table.
Looking now has changed a bit around the 8 20 32 deg c areas
I will load up now this table and alter those areas making it leaner by .3

Is that what your wanting me to try ?

Yes is a glitch at 20% tps and 32deg c i will blend that in
Attachments
orig dyno start fuel.jpg
orig dyno start fuel.jpg (106.41 KiB) Viewed 209 times

User avatar
Posts: 280
Joined: Sun Oct 28, 2012 12:57 pm

Re: Cold start car stalls when taking off help needed

Postby 'quipt4it » Wed Mar 31, 2021 11:29 am

I think try the other suggestions. You're not in the 32 degree band now anyway. That is 20 MAP lol
Go back over the last few posts and you'll see them.

Posts: 272
Joined: Wed May 19, 2010 2:21 pm

Re: Cold start car stalls when taking off help needed

Postby vp304 » Wed Mar 31, 2021 12:15 pm

Sorry was in a rush when I typed it
20 map not Tps.

Let the car sit for 4 hours and started it just then.
I leaned of this section see picture below.
started better tho still stalled when I tried to take of in drive.
Attachments
IMG_20210331_123641.jpg

User avatar
Posts: 280
Joined: Sun Oct 28, 2012 12:57 pm

Re: Cold start car stalls when taking off help needed

Postby 'quipt4it » Wed Mar 31, 2021 1:17 pm

Time to look into these, as I have suggested previously;
First Stage Crank Base Pulse Width vs Coolant Temp
Transient/ Manifold Fuel: RPM gain factor for Manifold fuel calc. and Transient - AE Gain vs Delta manifold fuel.
Crank Decay Step size.

Posts: 272
Joined: Wed May 19, 2010 2:21 pm

Re: Cold start car stalls when taking off help needed

Postby vp304 » Wed Mar 31, 2021 2:37 pm

OK which one would should I look at 1st.

User avatar
Posts: 280
Joined: Sun Oct 28, 2012 12:57 pm

Re: Cold start car stalls when taking off help needed

Postby 'quipt4it » Wed Mar 31, 2021 3:39 pm

1. First Stage Crank Base Pulse Width vs Coolant Temp.
2. Crank Decay Step size.
3. Transient - AE Gain vs Delta manifold fuel.
4. Transient/ Manifold Fuel: RPM gain factor for Manifold fuel calc.
Experiment either way until you are sure there is a positive result.

PreviousNext

Return to General Tuning Discussion

Who is online

Users browsing this forum: No registered users and 3 guests