Haltech E6X no spark?

A place For General Chit Chat Etc
Site Admin
User avatar
Posts: 6509
Joined: Sat Feb 28, 2009 8:34 pm

Haltech E6X no spark?

Postby antus » Fri Mar 13, 2009 3:41 pm

Ive got a haltech e6x ecu with MSD DIS-4 ignition in a turbo track gemini. Its running 18 pounds boost, and has 240rwkw. Last time on the track I was experimenting hitting the brakes later and later at the end of the straight. Naturally eventually I pushed too hard and put it in the kitty litter. Track officials towed me out OK but after that my ignition started degrading. It wouldnt go hard under full load and gradually got worse. 20 mins later I couldnt even start it. Anyone heard of anything like this before? Suggestions what to check?
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

User avatar
Posts: 10075
Joined: Sat Feb 28, 2009 9:05 pm
Location: Tenambit, NSW

Re: Haltech E6X no spark?

Postby Holden202T » Fri Mar 13, 2009 10:01 pm

i'd be looking at the msd first .... i guess you want to know if its actually getting a spark at all. ...

i had a problem with my torana once, drove home from work fine, go to start the car a few hrs later and it would fire just as i was letting the key off ....

ended up being a faulty coil .... once it got late enough i could see the spark zapping out the side of the coil to the closest earth!!

User avatar
Posts: 4991
Joined: Sun Mar 01, 2009 2:54 pm
Location: Perth, WA

Re: Haltech E6X no spark?

Postby VL400 » Sun Mar 15, 2009 3:45 pm

The MSD is not called a May Suddenly Die for no reason! haha

May just be a dirty pickup?? What type of pickup are you using??

Site Admin
User avatar
Posts: 6509
Joined: Sat Feb 28, 2009 8:34 pm

Re: Haltech E6X no spark?

Postby antus » Sun Mar 15, 2009 8:29 pm

Yeah sounds like spark. I'll have to get the car off the trailer and have a look at it some time before the next track day. Its more likely the msd than the pickup, as the failure was load related, not rpm related.
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

Posts: 30
Joined: Thu Mar 05, 2009 9:07 pm

Re: Haltech E6X no spark?

Postby XR Pilot » Sun Mar 15, 2009 8:42 pm

If it were me I'd be looking into the HT side - coil/MSD/leads etc because as you said, the problem is load related not rpm related. It is pretty unusual for a pickup to slowly die, they usually either stop working completely or give problems at a certain rpm, and ususually that happens from the moment they are fitted.

Is the setup multi-coil or dizzy based? If its dizzy based, it would be worth checking the dizzy cap and rotor for cracks and arcing.

Site Admin
User avatar
Posts: 6509
Joined: Sat Feb 28, 2009 8:34 pm

Re: Haltech E6X no spark?

Postby antus » Sun Mar 15, 2009 9:43 pm

2x wasted spark coils up the back of the engine there
msd.jpg

sr20.jpg
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

Site Admin
User avatar
Posts: 6509
Joined: Sat Feb 28, 2009 8:34 pm

Re: Haltech E6X no spark?

Postby antus » Sun Mar 15, 2009 9:59 pm

ce_1.jpg
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

Posts: 30
Joined: Thu Mar 05, 2009 9:07 pm

Re: Haltech E6X no spark?

Postby XR Pilot » Sun Mar 15, 2009 10:15 pm

Ok now I know you've got an S13 SR20DET I know a bit more about the setup :D

If the NIssan CAS is unmodified, it MAY be worth checking that out, swap it with a good one if possible. The only reason I say that is because I have only ever once seen a Nissan CAS cause starting issues and breakdown under load, yet once started it would idle and run fine under light load. It was on an RB25DE in an R32 (factory fitted, pretty rare). The CAS was eventually swapped on a whim and the problem went away. Once the CAS was disassembled the problem was found - the bearing inside had disintegrated and the whole housing was full of crap and rust from where it had pretty much imploded :lol:

Site Admin
User avatar
Posts: 6509
Joined: Sat Feb 28, 2009 8:34 pm

Re: Haltech E6X no spark?

Postby antus » Tue Mar 17, 2009 11:48 am

Ive been doing a bit of reading and price checking on MSD-DIS4 plus ignition. It seems to me like its a stand alone ignition controller and that I dont even need it. From this haltech wiring diagram, I think I could just remove it and drive the coils directly from the ecu. Does this sound right? If I dont need the dis-4 and it has died, then that looks the way to go.
Attachments
e6x_wiring2.jpg
e6x_wiring2.jpg (180.36 KiB) Viewed 4773 times
Have you read the FAQ? For lots of information and links to significant threads see here: viewtopic.php?f=7&t=1396

User avatar
Posts: 4991
Joined: Sun Mar 01, 2009 2:54 pm
Location: Perth, WA

Re: Haltech E6X no spark?

Postby VL400 » Tue Mar 17, 2009 11:59 am

The DIS-4 is a CDI igntion booster, handy but if you have a resonable inductive setup it may not be needed. But you will still need to add an ignition module between the coils and the haltech, it can only drive a module not the coil directly. May also need different coils if they have been changed for CDI ones?

Next

Return to Off Topic

Who is online

Users browsing this forum: No registered users and 12 guests