VY V6 feels like lean surge going up hills

160 And 8192 Baud Aldl
Posts: 5
Joined: Thu Feb 27, 2020 2:59 pm
Location: South Australia

VY V6 feels like lean surge going up hills

Postby Mag107 » Thu Feb 27, 2020 5:27 pm

Hello Guys n Girls ;)

I am new to Tuner Pro RT and just done data logging yesterday on my V6 and wondered if someone could look over my XDL file :thumbup:

I have changed those manifold gaskets (oil in the coolant) - spark plugs - cleaned throttle body and IAC - cleaned the MAF - checked all vac lines - leads checked ok with ohms readings and they don't arc anywhere at night in the dark with water misted over them.

When the ALDL cable is plugged into the PC and car the check engine light comes on and 1 of the fans turns on, the engine coolant temp stops reading on the dash and I can't use the A/C :wtf:

Engine is Stock with a washable air cleaner and sport exhaust.

I think it's fuel pressure but can't see anywhere to connect a gauge too :cry:

If you view the data you will note when it gets lean the knock sensors start reducing the timing of the cylinders.
Attachments
test 2.xdl
(1.58 MiB) Downloaded 123 times

Posts: 5
Joined: Thu Feb 27, 2020 2:59 pm
Location: South Australia

Re: VY V6 feels like lean surge going up hills

Postby Mag107 » Tue Mar 10, 2020 11:39 pm

Just a up date I have (today) installed a Aeroflow NTP port with a Aeroflow 100psi fuel pressure gauge..
Depends on who you talk too as to what my fuel pressure should be, 290-410kPa or 42 - 60psi.
Mine reads 42psi with ignition on and just over 40 with the engine running and if I take the vac line off the regulator it goes up to 50psi..
I read it should be 50psi at idle, anyone got a factory workshop manual?

User avatar
Posts: 9968
Joined: Sat Feb 28, 2009 9:05 pm
Location: Tenambit, NSW

Re: VY V6 feels like lean surge going up hills

Postby Holden202T » Thu Mar 12, 2020 3:36 pm

i would say 50psi at idle without the vacuum line, but will be closer to 43psi with the vacuum line on.

i think you will find though, get an idea of what it is at zero vacuum, in your case the 50psi with no vacuum line, thats what you should see at full throttle, or more likely anything low revs over about 30-40% throttle will probably be zero vacuum.

probably what you want to see is, if the vacuum isn't changing, but the fuel pressure is dropping then you have an issue .... and you will more than likely see it at higher revs/higher load it will go lean.

Posts: 5
Joined: Thu Feb 27, 2020 2:59 pm
Location: South Australia

Re: VY V6 feels like lean surge going up hills

Postby Mag107 » Mon Mar 16, 2020 7:52 pm

Holden202T wrote:i would say 50psi at idle without the vacuum line, but will be closer to 43psi with the vacuum line on.

i think you will find though, get an idea of what it is at zero vacuum, in your case the 50psi with no vacuum line, thats what you should see at full throttle, or more likely anything low revs over about 30-40% throttle will probably be zero vacuum.

probably what you want to see is, if the vacuum isn't changing, but the fuel pressure is dropping then you have an issue .... and you will more than likely see it at higher revs/higher load it will go lean.


Thanks for the reply ;)

The fuel pressure is not dropping at WOT so that's good and I have been looking at my engine data again and I noticed that the lean starts when it goes into closed loop, so the CPU then runs off it's own fuel map that's been programmed into it.
So as far as I know it won't read what the 0-2's are doing and it won't do any short or long term fuel trims either and I think the inputs the CPU would be looking at would be MAF so it know's how much air is going in and the throttle position sensor?

Based on that I have worked out the some of the fuel injectors are worn out or partially blocked.

The plenum is off again and waiting for my new Bosch injectors to arrive :thumbup:

User avatar
Posts: 295
Joined: Sun Jan 25, 2015 4:21 pm
Location: Sydney

Re: VY V6 feels like lean surge going up hills

Postby j_ds_au » Mon Mar 16, 2020 11:20 pm

Mag107 wrote:When the ALDL cable is plugged into the PC and car the check engine light comes on and 1 of the fans turns on, the engine coolant temp stops reading on the dash and I can't use the A/C :wtf:

That ain't right! What sort of cable is this? Sounds like it's faulty.

Joe.

Posts: 5
Joined: Thu Feb 27, 2020 2:59 pm
Location: South Australia

Re: VY V6 feels like lean surge going up hills

Postby Mag107 » Mon Mar 16, 2020 11:29 pm

j_ds_au wrote:
Mag107 wrote:When the ALDL cable is plugged into the PC and car the check engine light comes on and 1 of the fans turns on, the engine coolant temp stops reading on the dash and I can't use the A/C :wtf:

That ain't right! What sort of cable is this? Sounds like it's faulty.

Joe.


Thanks Joe,

It's a ALDL cable from Envyous Customs..

Posts: 460
Joined: Thu Nov 03, 2011 7:57 pm
Location: perth wa

Re: VY V6 feels like lean surge going up hills

Postby vs ss » Tue Mar 17, 2020 12:50 am

Yeah they kick stuff off the bus when you start playing with vt on, So you can loose gauges and on the Calais you loose variable speed steering and sometimes climate.
What you experiencing sounds like it’s going into lean cruise? This is normal and ignores the o2 sensor and goes into preset parameters. Depending on the model this can go as lean as 18:1 and it also alters timing too.

Posts: 5
Joined: Thu Feb 27, 2020 2:59 pm
Location: South Australia

Re: VY V6 feels like lean surge going up hills

Postby Mag107 » Tue Mar 17, 2020 2:32 pm

vs ss wrote:Yeah they kick stuff off the bus when you start playing with vt on, So you can loose gauges and on the Calais you loose variable speed steering and sometimes climate.
What you experiencing sounds like it’s going into lean cruise? This is normal and ignores the o2 sensor and goes into preset parameters. Depending on the model this can go as lean as 18:1 and it also alters timing too.


Thanks for the reply,

Yeah they kick stuff off the bus well annoying but not a problem then :thumbup:

Yes it does seems like it's into lean cruise but when it happens it is in open loop and going up hills..

User avatar
Posts: 295
Joined: Sun Jan 25, 2015 4:21 pm
Location: Sydney

Re: VY V6 feels like lean surge going up hills

Postby j_ds_au » Tue Mar 17, 2020 9:52 pm

vs ss wrote:Yeah they kick stuff off the bus when you start playing with vt on, So you can loose gauges and on the Calais you loose variable speed steering and sometimes climate.
What you experiencing sounds like it’s going into lean cruise? This is normal and ignores the o2 sensor and goes into preset parameters. Depending on the model this can go as lean as 18:1 and it also alters timing too.

Thanks for that info.

Wow! Doesn't that make logging and RT tuning futile?

Joe.

Return to ALDL, OBDII Logging and Scanning

Who is online

Users browsing this forum: No registered users and 2 guests